Primaaprilisowe RFC – w prawie każdy prima aprilis (1 kwietnia) od 1989 roku Internet Engineering Task Force publikuje jeden lub więcej humorystycznych RFC. Pierwszy ukazał się w 1978 roku, a po 11 latach zaczęto regularnie, co roku publikować kolejne, z pominięciem roku 2006, w którym, zamiast humorystycznego RFC, 1 kwietnia opublikowano ogłoszenie na liście mailingowej IETF na temat mianowania Huberta, postaci z Ulicy Sezamkowej, członkiem Internet Architecture Board.

Przed primaaprilisowymi publikowane były również inne humorystyczne RFC. Pierwszy ukazał się w czerwcu 1973 roku, był to RFC 527 zatytułowany ARPAWOCKY, który parodiował wiersz Jabberwocky Lewisa Carrolla. Poniższa lista zawiera również humorystyczne RFC publikowane w dniach innych niż 1 kwietnia.

IETF przyjmuje propozycje poprawnie sformatowanych primaaprilisowych RFC od ogółu społeczeństwa i rozważa ich publikację tego samego roku, jeśli zostały przysłane co najmniej 2 tygodnie przed 1 kwietnia.

Zbiór primaaprilisowych RFC ukazał się w książce The Complete April Fools' Day RFCs.

Lista primaaprilisowych RFC + Numer Tytuł Autorzy Data publikacji Uwagi RFC 748 TELNET Randomly-Lose Option Mark Crispin 1 kwietnia 1978 Parodia stylu dokumentacji TCP/IP. Ponieważ niektórzy brali ją na poważnie, przez długi czas była specjalnie oznaczona w indeksie RFC: zwróć uwagę na datę wydania. RFC 1097 TELNET Subliminal-Message Option B. Miller 1 kwietnia 1989 RFC 1149 Standard for the transmission of IP datagrams on Avian Carriers David Waitzman 1 kwietnia 1990 Zaktualizowane przez RFC 2549 (porównaj poniżej). Zaimplementowany w 2001 roku przez Linux User Group z Bergen. RFC 1216 Gigabit Network Economics and Paradigm Shifts Poorer Richard, Prof. Kynikos 1 kwietnia 1991 RFC 1217 Memo from the Consortium for Slow Commotion Research (CSCR) Vint Cerf 1 kwietnia 1991 RFC 1313 Today's Programming for KRFC AM 1313 Internet Talk Radio C. Partridge 1 kwietnia 1992 Niektóre części tego RFC są zdezaktualizowane, np. przesunięcie Dopplera w czasie lotu Concordem nie jest już problemem, ponieważ samoloty te zostały wycofane z użycia. RFC 1437 The Extension of MIME Content-Types to a New Medium Nathaniel Borenstein, M. Linimon 1 kwietnia 1993. RFC 1438 Internet Engineering Task Force Statements of Boredom (SOBs) A. Lyman Chapin, C. Huitema 1 kwietnia 1993 RFC 1605 Synchronous Optical Networking to Sonnet Translation William Shakespeare 1 kwietnia 1994 RFC 1606 A Historical Perspective on the Usage of IP Version 9 J. Onions 1 kwietnia 1994 RFC 1607 A View from the 21st Century Vint Cerf 1 kwietnia 1994 RFC 1776 The Address Is the Message Steve Crocker 1 kwietnia 1995 Propozycja nowego formatu datagramu, który składałby się jedynie z adresów odbiorców. Wskazano, że jest to przełom w dziedzinie bezpieczeństwa, choć pominięto analizę tych kwestii. RFC 1924 A Compact Representation of IPv6 Addresses R. Elz 1 kwietnia 1996 Propozycja użycia kodowania base85 do zwartego zapisu adresów IPv6 za pomocą 20 znaków. Mimo daty wydania sugerującej żart, specyfikacja znalazła praktyczne zastosowanie. RFC 1925 The Twelve Networking Truths R. Callon 1 kwietnia 1996 RFC 1926 An Experimental Encapsulation of IP Datagrams on Top of ATM J. Eriksson 1 kwietnia 1996 RFC 1927 Suggested Additional MIME Types for Associating Documents C. Rogers 1 kwietnia 1996 RFC 2100 The Naming of Hosts J. Ashworth 1 kwietnia 1997 RFC 2321 RITA – The Reliable Internetwork Troubleshooting Agent A. Bressen 1 kwietnia 1998 RFC 2322 Management of IP Numbers by peg-dhcp K. van den Hout et al 1 kwietnia 1998 RFC 2323 IETF Identification and Security Guidelines A. Ramos 1 kwietnia 1998 RFC 2324 Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0) L. Masinter 1 kwietnia 1998 RFC 2325 Definitions of Managed Objects for Drip-Type Heated Beverage Hardware Devices using SMIv2 M. Slavitch 1 kwietnia 1998 RFC 2549 IP over Avian Carriers with Quality of Service D. Waitzman 1 kwietnia 1999 Rozszerzenie RFC 1149 opisanego wyżej. RFC 2550 Y10K and Beyond S. Glassman, M. Manasse, J. Mogul 1 kwietnia 1999 RFC 2551 The Roman Standards Process – Revision III Scott Bradner 1 kwietnia 1999 RFC 2795 The Infinite Monkey Protocol Suite (IMPS) S. Christey 1 kwietnia 2000 RFC 3091 Pi Digit Generation Protocol H. Kennedy 1 kwietnia 2001 RFC 3092 Etymology of "Foo" D. Eastlake 3rd, C. Manros, Eric S. Raymond 1 kwietnia 2001 RFC 3093 Firewall Enhancement Protocol (FEP) M. Gaynor, Scott Bradner 1 kwietnia 2001 RFC 3251 Electricity over IP B. Rajagopalan 1 kwietnia 2002 RFC 3252 Binary Lexical Octet Ad-hoc Transport H. Kennedy 1 kwietnia 2002 RFC 3514 The Security Flag in the IPv4 Header (Evil Bit) Steven M. Bellovin 1 kwietnia 2003 RFC 3751 Omniscience Protocol Requirements Scott Bradner 1 kwietnia 2004 RFC 4041 Requirements for Morality Sections in Routing Area Drafts Adrian Farrel 1 kwietnia 2005 RFC 4042 UTF-9 and UTF-18 Efficient Transformation Formats of Unicode Mark Crispin 1 kwietnia 2005 Zawierał kod asemblerowy PDP-10 prawie 22 lata po rezygnacji z tej architektury przez jej producenta. RFC 4824 The Transmission of IP Datagrams over the Semaphore Flag Signaling System (SFSS) Jogi Hofmueller, Aaron Bachmann, IOhannes zmoelnig 1 kwietnia 2007 Zaimplementowany przez autorów w ramach projektu Talking the Fish. RFC 5241 Naming Rights in IETF Protocols A. Falk, Scott Bradner 1 kwietnia 2008 RFC 5242 A Generalized Unified Character Code: Western European and CJK Sections John Klensin, Harald Tveit Alvestrand 1 kwietnia 2008 RFC 5513 IANA Considerations for Three Letter Acronyms Adrian Farrel 1 kwietnia 2009 RFC 5514 IPv6 over Social Networks E. Vyncke 1 kwietnia 2009 Zaimplementowany na Facebooku. RFC 5841 TCP Option to Denote Packet Mood R. Hay, W. Turkal 1 kwietnia 2010 RFC 6217 Regional Broadcast Using an Atmospheric Link Layer. T. Ritter 1 kwietnia 2011 RFC 6592The Null PacketC. Pignataro 1 kwietnia 2012 RFC 6593Service Undiscovery Using Hide-and-Go-Seek for the Domain Pseudonym System (DPS)C. Pignataro, J. Clarke, G. Salgueiro 1 kwietnia 2012 RFC 7511Scenic Routing for IPv6 M. Wilhelm 1 kwietnia 2015RFC 7514Really Explicit Congestion Notification (RECN)M. Luckie 1 kwietnia 2015

Inne humorystyczne RFC + Numer Tytuł Autorzy Data publikacji Uwagi RFC 439 PARRY Encounters the DOCTOR V. Cerf 21 stycznia 1973 PARRY spotyka DOKTORA RFC 527 ARPAWOCKY R. Merryman, UCSD 22 czerwca 1973 Parodia wiersza Lewisa Carrolla pt. Jabberwocky RFC 968 Twas the Night Before Start-up V.G. Cerf 1 grudnia 1985 RFC 1882 The 12-Days of Technology Before Christmas B. Hancock grudzień 1995

Przypisy

Bibliografia

Linki zewnętrzne

Kategoria:Humor internetowy Kategoria:Standardy internetowe