Тонкі кліент () у камп’ютарных тэхналогіях — камп’ютар ці праграма- кліент у сетках з кліент-сервернай ці тэрмінальнай архітэктурай, які пераносіць усе альбо большую частку задач па апрацоўцы інфармацыі на сервер. Узорам тонкага кліента можа служыць камп’ютар з браўзерам, які выкарыстоўваеца для работы з вэб-праграмамі.
Web-кліенты () Web-кліент як праграма — браўзер. Web-кліент як прылада — прылада, асноўным ужываннем якога (с пункту гледжання распрацоўшчыка прылады ці маркетолага) з’яўляецца браўзер.
Тонкія кліенты, якія працуюць у тэрмінальным рэжыме Пад тэрмінам «тонкі кліент» маецца на ўвазе досыць шырокі з пункту гледжання сістэмнай архітэктуры шэраг прылад і праграм, якія аб’ядноўваюцца агульнай уласцівасцю: магчымасцю працы ў рэжыме сувязі з тэрміналам. Такім чынам, для працы тонкага кліента неабходны тэрмінальны сервер. Гэтым тонкі кліент адрозніваецца ад тоўстага кліента, які, наадварот, выконвае апрацоўку інфармацыі незалежна ад сервера, выкарыстоўваючы апошні ў асноўным толькі для захоўвання даных. thumb|right|180px|Параўнанне памераў — тонкі кліент (справа) у параўнанні з традыцыйным настольным ПК Акрамя агульнага выпадку, варта вылучыць апаратны тонкі кліент (напрыклад, Windows- і Linux-тэрміналы) — спецыялізаваную прыладу, якая прынцыпова адрозніваецца ад ПК. Апаратны тонкі кліент не мае цвёрдага дыска, выкарыстоўвае спецыялізаваную лакальную АС (адна з задач якой арганізаваць сесію з тэрмінальным серверам для працы карыстальніка), не мае ў сваім складзе рухомых дэталяў, вырабляецца ў спецыялізаваных карпусах з цалкам пасіўным астуджэннем.
Для пашырэння функцыянальнасці тонкага кліента ажыццяўляюць яго «патаўшчэнне» — напрыклад, дадаюць магчымасці аўтаномнай працы, захоўваючы галоўнае адрозненне — працу ў сесіі з тэрмінальным серверам. Калі ў кліенце з’яўляюцца рухомыя дэталі (цвёрдыя дыскі), з’яўляюцца магчымасці аўтаномнай працы, ён перастае быць тонкім кліентам у чыстым выглядзе, а становіцца ўніверсальным кліентам.
Тонкі кліент у большасці выпадкаў характэрызуецца мінімальнай апаратнай канфігурацыяй, замест цвёрдага дыска для загрузкі лакальнай спецыялізаванай АС выкарыстоўваецца DOM (DiskOnModule) [модуль з раз’ёмам IDE, флэш-памяццю і мікрасхемай, якая рэалізуе логіку звычайнага цвёрдага дыска — у BIOS вызначаецца як звычайны цвёрды дыск, толькі памер яго звычайна ў 2-3 разы менш]. У некаторых канфігурацыях сістэмы тонкі кліент загружае аперацыйную сістэму па сетцы з сервера, ужываючы пратаколы PXE, BOOTP, DHCP, TFTP і Remote Installation Services (RIS).
Пратаколы, якімі карыстаюцца тонкія кліенты X11 — ужываецца ў Unix Telnet — мультыплатформенны SSH — мультыплатформенны шыфраваны аналаг Telnet NX NoMachine — пратакол X11 з кампрэсаваннем дадзеных Virtual Network Computing Citrix Independent Computing Architecture(ICA) Remote Desktop Protocol (RDP), пратокол для дыстанцыйнай працы з ужываннем графічнага інтэрфейса карыстальніка для Microsoft Windows SPICE (Simple Protocol For Independent Computing Environments) Акрамя таго могуць ужывацца закрытыя пратаколы, створаныя распрацоўшчыкамі праграмнага забеспячэння.
Прыклады тонкіх кліентаў Thinstation LTSP OpenThinClient Бяздыскавая станцыя Тэрмінальны доступ Virtual Network Computing GrapeTC Lite WTWare
Гл. таксама Бяздыскавая працоўная станцыя Тоўсты кліент Jack PC Браўзер
Спасылкі RFC 1350 — апісанне пратакола TFTP RFC 2131 — апісанне пратакола DHCP RFC 854 — апісанне пратакола telnet RFC 951 і RFC 1542 — апісанне пратакола DHCP Усталёўка Remote Installtion Services (RIS) Апісанне RIS