thumb|400px|Схема працы DNS. Domain Name System (DNS; ) — іерархічная размеркаваная сістэма наймення камп’ютараў, службаў і іншых рэсурсаў, далучаных да Інтэрнэту ці прыватнай сеткі. DNS захоўвае звесткі пра даменныя імёны і злучае іх з удзельнікамі сеткі. Служба DNS займаецца апрацоўкай запытаў ад іншых удзельнікаў на развязанне сувязі паміж даменным імем і ўдзельнікам сеткі і вяртае крыніцы запыту выніковы адрас. Такім чынам, DNS з’яўляецца адной з найістотнейшых частак Інтэрнэту, без якой ён не можа функцыянаваць.
Асноўнай задачай DNS з’яўляецца пераўтварэнне імя хоста, зразумелага для чалавека, у IP-адрас, зразумелы для камп’ютара. Для ўзору: www.example.com будзе пераўтвораны ў адрасы 192.0.43.10 (IPv4) і 2620:0:2d0:200::10 (IPv6). У гэтым служба DNS цалкам падобная да тэлефоннай кнігі, але звесткі ў DNS бесперапынна змяняюцца і абнаўляюцца, што дазваляе змяняць фактычны адрас рэсурса (IP-адрас), не змяняючы зручнае ў карыстанні даменнае імя ў адрасах электроннай пошты і URL.
Спасылкі
DNS Resources Directory Рэсурсы, прысвечаныя DNS & BIND Таварыства CircleID DNS Павышэнне бяспекі DNS (DNSSEC) Працоўны камітэт IETF які займаецца распрацоўкай пашыранай спецыфікацыі DNS (DNSEXT) Сайт каранёвых DNS-сервераў Вэб-інструменты для DNS, каталог на сайце dmoz.org
Дакументы RFC RFC 1034 — Domain Names — Concepts and Facilities RFC 1035 — Domain Names — Implementation and Specification RFC 1912 — Common DNS Operational and Configuration Errors RFC 1591 — Domain Name System Structure and Delegation RFC 1713 — Tools for DNS Debugging RFC 2606 — Reserved Top Level DNS Names
Катэгорыя:Стандарты Інтэрнэту Катэгорыя:TCP/IP
Катэгорыя:Інтэрнэт-пратаколы