Typ internetového média, původně označovaný jako typ MIME podle MIME (Multipurpose Internet Mail Extensions, česky „víceúčelová rozšíření internetové pošty“) a někdy také Content-type podle hlavičky některých protokolů, jejíž hodnotou je právě takový typ, je dvoudílný identifikátor formátu souboru na Internetu. Identifikátory byly původně definovány v RFC 2046 pro použití v e-mailových zprávách posílaných přes SMTP, jejich použití však expandovalo i do jiných protokolů, například HTTP, RTP nebo SIP.
Typ média je složen nejméně ze dvou částí: typu, podtypu a jednoho čí více nepovinných parametrů. Například podtypy typu text (textová data) mají nepovinný parametr charset, který lze uvést pro informaci o kódování znaků. Podtypy typu multipart (data složená z více částí) často definují parametr boundary popisující znakovou sekvenci ohraničující jednotlivé části dat.
Typy a podtypy, které začínají x., jsou nestandardní (nejsou registrovány organizací IANA). Podtypy začínající vnd. jsou specifické pro konkrétního tvůrce (dodavatele). Podtypy v osobním stromě začínají prs..
MIME je zkratka pro Multipurpose Internet Mail Extensions, specifikaci pro formátování ne-ASCII zpráv do podoby, aby mohly být posílány přes Internet. Mnoho e-mailových klientů nyní MIME podporuje, mohou tak posílat grafiku, zvukové soubory a videosoubory přes internetový poštovní systém.
Existuje mnoho předdefinovaých typů MIME, například pro grafické soubory GIF nebo postscriptové soubory. Lze si také nadefinovat své vlastní typy MIME.
Kromě e-mailových aplikací je mnoho typů MIME podporováno také webovými prohlížeči. To umožňuje zajistit, aby prohlížeče zobrazovaly nebo zpracovávaly soubory, které nejsou ve formátu HTML.
Technologie MIME byla definována v roce 1992 v Internet Engineering Task Force (IETF). Nová verze, nazvaná S/MIME, podporuje šifrované zprávy.
Některé často používané typy médií IANA spravuje registr typů médií a kódování znaků – a zveřejňuje také jejich seznam. Některé významné typy jsou uvedeny níže: typ application: víceúčelové (aplikační) soubory application/EDI-X12: data EDI X12; definováno v RFC 1767 application/EDIFACT: data EDI EDIFACT; definováno v RFC 1767 application/json: JavaScript Object Notation JSON; definováno v RFC 4627 application/javascript: JavaScript; definováno v RFC 4329, avšak neakceptováno v IE 8 a starších verzích application/octet-stream: obecná binární datahttp://tools.ietf.org/html/rfc2046. Obecně řečeno, tento typ identifikuje soubory, které nejsou spjaty s žádnou specifickou aplikací. V rozporu s dřívějšími předpoklady softwarových produktů, jako je např. Apache, toto není typ, který by se měl používat pro neznámé soubory. V takových případech by server nebo aplikace neměly indikovat typ obsahu, protože může být chybný; místo toho by měla být identifikace typu vynechána, aby příjemce zkusil správný typ uhodnout.http://www.w3.org/Protocols/rfc2616/rfc2616-sec7.html#sec7.2.1 application/ogg: Ogg, multimediální bitstreamový kontejnerový formát; definován v RFC 5334 application/pdf: Portable Document Format (PDF), používá se pro výměnu dokumentů na Internetu od roku 1993; definován v RFC 3778 application/soap+xml: SOAP; definováno v RFC 3902 application/xhtml+xml: XHTML; definováno v RFC 3236 application/xml-dtd: soubory DTD; definováno v RFC 3023 application/zip: soubory archivů ZIP typ audio: zvuková data audio/basic: zvuková data mulaw vzorkovaná na 8 kHz, 1 kanál; definováno v RFC 2046 audio/mp4: zvuková data MP4 audio/mpeg: MP3 nebo jiný zvukový soubor MPEG; definováno v RFC 3003 audio/ogg: Ogg Vorbis, Speex, Flac a jiná zvuková data; definováno v RFC 5334 audio/vorbis: zvuk kódovaný jako Vorbis; definováno v RFC 5215 audio/x-ms-wma: Windows Media Audio; dokumentováno v Microsoft KB 288102 audio/x-ms-wax: přesměrování Windows Media Audio; dokumentováno v Microsoft help page audio/vnd.rn-realaudio: RealAudio; dokumentováno v RealPlayer Customer Support Answer 2559 audio/vnd.wave: zvuková data WAV; definováno v RFC 2361 typ image: obrázky image/gif: obrázek GIF; definováno v RFC 2045 a RFC 2046 image/jpeg: obrázek JPEG JFIF; definováno v RFC 2045 a RFC 2046 image/png: Portable Network Graphics; definováno v RFC 2083 image/svg+xml: vektorový obrázek SVG; definováno v SVG Tiny 1.2 Specification Appendix M image/tiff: Tagged Image File Format; definováno v RFC 3302 image/x-icon: obrázek ICO typ text: texty text/plain: text/csv: text/css: text/html: typ video: video soubory video/mp4:
Reference
Externí odkazy IANA MIME media types list RFC 2045, RFC 2046 – Multipurpose Internet Mail Extensions (MIME), parts 1 and 2
Kategorie:MIME Kategorie:Souborové formáty Kategorie:Internet