SIGTRAN (zkratka ze ) je rodina protokolů, která umožňuje IP sítí přenášet telefonní síťovou signalizaci Signalizačního systému č. 7, účastnickou signalizaci nebo propojovat telefonní ústředny s multiplexory. Název byl převzat ze jména pracovní skupiny Internet Engineering Task Force (IETF), která tuto sadu protokolů vytvořila.
SIGTRAN představuje první krok konvergence telefonních sítí a IP sítí, ve kterém jsou vyšší vrstvy jako ISUP, TCAP a MAP ponechány beze změny, ale drahá a špatně škálovatelná tradiční (legacy) SS7 infrastruktura je nahrazena IP infrastrukturou, přičemž MTP1, MTP2 a volitelně i MTP3 a SCCP jsou nahrazeny internetovými protokoly. Místo obvyklých transportních protokolů IP sítí (TCP a UDP), používá SIGTRAN protokol SCTP, který nad IPv4 nebo IPv6 poskytuje spolehlivý přenos datagramů v několika proudech a dovoluje zvýšení spolehlivosti díky používání multihomed uzlů tvořených více stroji. SCTP se využívá jako nosič adaptačních protokolů pro Signalizační systém č. 7 (SS7) jako M2PA, M2UA, M3UA a SUA a komunikačních protokolů používaných telefonními a ISDN sítěmi. Použitelnost rodiny protokolů SS7 se tak rozšiřuje i na IP sítě při zachování SS7 aplikací a částečně i přístupu ke správě sítě. O protokolu SCTP se také uvažuje jako o jedné z možných náhrad protokolu TCP v případech, kdy jeho vlastnosti nevyhovují (například pro spolehlivý přenos datagramů a pro přenosy na vysokorychlostních linkách s vysokou latencí).
Na obrázku znázorňujícím protokolový zásobník SIGTRAN je protokol SCTP, který patří do transportní vrstvy, situován do vrstvy síťové. Nejedná se o chybu, je to důsledek toho, že se vlastně jedná o tunelování SS7 protokolů skrz IP síť.
Protokolový zásobník Signaling System 7 Vrstvy referenčního Tradiční | SIGTRAN modelu SS7 | IP7 OSI +----------+ +-------------+ +--------------------------+ | MAP | | (Circuit | | MAP (GSM nebo IS-41) | | INAP | | Related) | | INAP, CAP | | CAP | | | | | 4 - 7 +----------+ | ISUP | +--------------------------+ | TCAP | | | | TCAP (ITU nebo ANSI) | +----------+ | | +-------------+------------+ -------------- | SCCP | | | | SCCP | | +----------+----+-----+-------+---------+---+---------+ | | | MTP3 | | SUA | + +----------+----------+ M3UA | | | MTP3 | M2PA | M2UA | | | 3 - síťová + +----------+----------+---------+------------+ | | SCTP | | +--------------------------------------------+ | | IP | +----------+----------+--------------------------------------------+ -------------- | MTP2 | | | 2 - linková +----------+ ATM | různé protokoly | -------------- | MTP1 | | | 1 - fyzická +----------+----------+--------------------------------------------+ --------------
Protokoly SIGTRAN se někdy označují zkratkou IP7. Nemá to znamenat novou verzi protokolu IP, je to pouze kombinace zkratek IP a SS7.
Skupina SIGTRAN byla významně ovlivněna záměrem použít nové protokoly pro propojení VoIP sítí s tradičními PSTN s co nejmenším dopadem na signalizaciRussell 2002, s. 456. Základním dokumentem pro SIGTRAN je RFC 2719 (Framework Architecture for Signaling Transport), který definuje koncept signalizační brány (), která provádí obousměrný převod signalizačních zpráv Common Channel Signaling (CCS) mezi SS7 a SIGTRANem.
Novějším přístupem ke konvergenci telefonních a IP sítí je IMS – IP Multimedia Subsystem, jehož těžiště je v IP sítích používajících signalizační protokol Session Initiation Protocol (SIP) a interoperabilitu se staršími sítěmi zajišťuje pomocí bran a protokolových konvertorů.
SIGTRAN protokoly Rodina protokolů SIGTRAN zahrnuje:
SCTP – Stream Control Transmission Protocol, RFC 2960, RFC 3873, RFC 4166, RFC 4960. Slouží pro přenos zpráv adaptačních vrstev IP sítí. M2PA – Message Transfer Part 2 (MTP) User Peer-to-Peer Adaptation Layer, RFC 4165. M2UA – Message Transfer Part 2 User Adaptation Layer, RFC 3331. M3UA – Message Transfer Part 3 User Adaptation Layer, RFC 4666. SUA – Signalling Connection Control Part (SCCP) User Adaptation, RFC 3868. V5UA – V5 User Adaptation, RFC 3807. IUA – ISDN User Adaptation, RFC 4233, RFC 5133. DUA – DPNSS/DASS2 User Adaption, RFC 4129
Jednotlivé prvky sítě nepoužívají všechny uvedené adaptační protokoly, ale obvykle jen 1 nebo 2 z nich.
M2UA M2UA slouží k připojení IP zařízení do SS7 sítě. IP zařízení se označuje IPSP (IP Signaling Point), má přiřazen vlastní Point Code (PC) a pro jeho připojení k SS7 síti je potřeba Signalling Gateway (SG). IPSP bývá nejčastěji MGC (Media Gateway Controller), které komunikuje na SS7 straně s SSP (Service Switching Point – ústředna v pevných sítích). NIF (Nodal Inter-working Function) v SG realizuje propojení na úrovni MTP2.
SEP (SSP) IPSP (MGC nebo SCP) +----+-----+ +----+---+-----+ | MAP| | | MAP| | | |INAP| I | |INAP| I | | | CAP| S | | CAP| S | | +----+ U | +----+ U | S | |TCAP| P | |TCAP| P | I | +----+ | +----+ | P | |SCCP| | SG |SCCP| | | +----+-----+ +----------------+ +----+---+ | | MTP3 | | NIF | | MTP3 | | +----------+ +--------+-------+ +--------+-----+ | MTP2 | | MTP2 | M2UA | | M2UA |TCP/ | | | | | SCTP | | SCTP | UDP | +----------+ +--------+-------+ +--------+-----+ | MTP1 | | MTP1 | IP | | IP | +----------+ +--------+-------+ +--------------+ | PC | | PC | +---------------+ +-------------------+ SS7 IP
M2PA M2PA má nejvíce použití, ale je nejsložitější. SG může sama fungovat jako SCP, STP nebo SSP. Přes SG může být připojeno několik zařízení v IP síti (neboli vytvoření SS7 linky v IP síti). Pro emulaci linksetu s několika signaling linkami je nutné tolik SCTP asociací, kolik linek se emuluje. Každé zařízení má vlastní point code (PC).
SEP (SSP) SG (IPSP) IPSP +----+-----+ +-----------+----+ +----+---+ | MAP| | | MAP | | | MAP| | |INAP| I | | INAP | I | |INAP| I | | CAP| S | | CAP | S | | CAP| S | +----+ U | +-----------+ U | +----+ U | |TCAP| P | | TCAP | P | |TCAP| P | +----+ | +-----------+ | +----+ | |SCCP| | | SCCP | | |SCCP| | +----+-----+ +-----------+----+ +----+---+ | MTP3 | | MTP3 | MTP3 | | MTP3 | +----------+ +--------+-------+ +--------+ | MTP2 | | MTP2 | M2PA | | M2PA | | | | | SCTP | | SCTP | +----------+ +--------+-------+ +--------+ | MTP1 | | MTP1 | IP | | IP | +----------+ +--------+-------+ +--------+ etc. | PC | PC | PC | PC | +---------------+ +--------------+-----------+ SS7 IP
M3UA
M3UA umožňuje vytvoření kombinované infrastruktury, ve které jsou některé prvky v SS7 síti a jiné v IP síti. Pokud není potřeba propojení s legacy SS7 sítí, není potřeba používat SG. Zařízení v IP síti nemusí mít nutně vlastní Point Code (PC).
SEP (SSP) SG (IPSP) IPSP IPSP … +----+-----+ +-------------+ +----+---+ | | | | MAP | | | | | MAP| | | INAP | | MAP| | |INAP| | | CAP | |INAP| | | CAP| I | +-------------+ | CAP| I | | | S | | TCAP | | | S | +----+ U | +-------------+ +----+ U | |TCAP| P | | SCCP | |TCAP| P | +----+ | +-------------+ +----+ | |SCCP| | | NIF | |SCCP| | +----------+ +------+------+ +--------+ | MTP3 | | MTP3 | M3UA | | M3UA | | MTP2 | | MTP2 | SCTP | | SCTP | | MTP1 | | MTP1 | IP | | IP | +----------+ +------+------+ +--------+ etc. | PC | PC | (PC)| (PC)| +---------------+ +--------------+---------+ SS7 IP
SUA SUA slouží k připojení jednoho nebo více IP zařízení do SS7 sítě. Jednotlivá zařízení nemají vlastní kódy signalizačního bodu (Point Code, PC), ale používají jediný PC přidělený signalling gatewayi (SG), která je při použití SUA nezbytná. Toto omezení může být v některých případech výhodou – protože SCP používá adresu PC patřící signalizační bráně, není nutné v konfiguraci ostatních prvků sítě měnit PC příslušného SCP; více SCP lze rozlišit pomocí SSN; v IS-41 sítích musí mít středisko krátkých textových zpráv (SMS MC) jediný Point Code; pokud má výkonné SMS MC více uzlů, je použití M3UA problematické, zatímco se SUA to problém není.
Zkratka IPSP má odlišný význam než u M2PA a M2UA, znamená IP Signaling Process.
SEP (SSP) SG (IPSP) IPSP +----+-----+ +-------------+ +------+ | | | | MAP | | | | MAP| | | INAP | | MAP | |INAP| | | CAP | | INAP | | CAP| I | +-------------+ | CAP | | | S | | TCAP | | | +----+ U | +-------------+ +------+ |TCAP| P | | NIF | | TCAP | +----+ | +-------------+ +------+ |SCCP| | | SCCP | SUA | | SUA | +----------+ +------| | | | | MTP3 | | MTP3 +------+ +------+ | MTP2 | | MTP2 | SCTP | | SCTP | | MTP1 | | MTP1 | IP | | IP | +----------+ +------+------+ +------+ etc. | PC PC | | | | +---------------+ +-------------+---------+ SS7 IP
SUA má nejjednodušší protokolový zásobník; přenáší SCCP zprávy, proto nemůže být použita pro ISUP (který pracuje nad MTP3). SUA nemusí (ale může) používat adresování podle PC (Point Code). jednotlivé aplikace lze rozlišit pomocí SSN.
NIF pro SUA není standardizováno, SG funguje jako inteligentní router pro zprávy vyšších vrstev (TCAP, MAP, INAP, CAP). SG může fungovat i jako SCP.
V5UA V5UA poskytuje adaptační vrstvu pro bezešvý přenos uživatelských zpráv a pro služební rozhraní V5.2 mezi multiplexorem a ústřednou IP sítí (obdoba IUA).
AN SG MGC +-------+ +------+ | V5.2 | (NIF) | V5.2 | +-------+ +-------+-------+ +------+ | | | | V5UA | | V5UA | | | | +-------+ +------+ | LAPV5 | | LAPV5 | SCTP | | SCTP | | | | +-------+ +------+ | | | | IP | | IP | +-------+ +-------+-------+ +------+
+-------------+ +---------------+ LAPV5 IP
IUA IUA poskytuje adaptační vrstvu pro bezešvý přenos uživatelských zpráv služebního rozhraní Q.921 (LAPD) v ISDN pro realizaci páteřního připojení pomocí IP sítě. Podporuje Q.931 a QSIG.Dryburgh 2004, s. 444
EP SG MGC +-------+ +-------+ | Q.931 | (NIF) | Q.931 | +-------+ +-------+-------+ +-------+ | | | | IUA | | IUA | | | | +-------+ +-------+ | Q.921 | | Q.921 | SCTP | | SCTP | | | | +-------+ +-------+ | | | | IP | | IP | +-------+ +-------+-------+ +-------+
+-------------+ +---------------+ LAPD IP
DUA DUA je rozšíření IUA pro přenos zpráv signalizačních systémů Digital Private Network Signaling System 1 (DPNSS 1) a Digital Access Signaling System 2 (DASS 2) IP sítí. Používá se pro propojení mezi Pobočkovou telefonní ústřednou (PBX) a Media Gateway Controlerem (MGC).
PBX SG MGC +----------+ +----------+ | DPNSS L3 | (NIF) | DPNSS L3 | +----------+ +--------+-------+ +----------+ | | | | DUA | | DUA | | | | +-------+ +----------+ | DPNSS L2 | | DPNSS | SCTP | | SCTP | | | | L2 +-------+ +----------+ | | | | IP | | IP | +----------+ +--------+-------+ +----------+
+---------------+ +----------------+ DPNSS IP
Smluvené SCP porty a payload protokol identifikátory Adaptační protokoly mají přiřazeny následující smluvené SCTP porty a payload protokol identifikátory:
Protokol SCTP Port SCTP Payload Protocol Id M2UA 2904 2 M3UA 2905 3 M2PA 3635 5 SUA 14001 4 V5UA 5675 6 IUA 9900 1 DUA 10
Odkazy
Reference
Níže je odkaz na online verzi.
IETF RFC dokumenty RFC 2719 Architectural Framework for Signaling Transport (říjen 1999) RFC 2960 Stream Control Transmission Protocol (SCTP) (říjen 2000) (nahrazeno RFC 4960) (aktualizováno RFC 3309) RFC 3057 ISDN Q.921-User Adaptation Layer (únor 2001) (aktualizováno RFC 3807, nahrazeno RFC 4233) RFC 3257 Stream Control Transmission Protocol Applicability Statement (duben 2002) RFC 3331 Signaling System 7 (SS7) Message Transfer Part 2 (MTP2) — User Adaptation Layer (M2UA) (září 2002) RFC 3332 Signaling System 7 (SS7) Message Transfer Part 3 (MTP3) — User Adaptation Layer (M3UA) (září 2002) (nahrazeno RFC 4666) RFC 3788 Security Considerations for SIGTRAN Protocols (červen 2004) RFC 3807 V5.2-User Adaption Layer (V5UA) (červen 2004) RFC 3873 Stream Control Transmission Protocol Management Information Base (září 2004) RFC 3868 Signalling Connection Control Part User Adaptation Layer (SUA) (říjen 2004) RFC 4165 Signaling System 7 (SS7) Message Transfer Part 2 (MTP2) — User Peer-to-Peer Adaptation Layer (M2PA) (září 2005)