Structure of Management Information, (SMI) je ve výpočetní technice upravená podmnožina ASN.1 používaná v Simple Network Management Protocol (SNMP) pro definování množin (“modulů“) příbuzných spravovaných objektů v Management Information Base (MIB).

SMI se skládá ze tří složek: definice modulů, definice objektů a definice notifikací.

Definice modulů se používají pro popis informačních modulů. Pro detailní popis sémantiky informačního modulu se používá ASN.1 makro MODULE-IDENTITY. Definice objektů popisují spravované objekty. Pro detailní popis syntaxe a sémantiky spravovaných objektů se používá ASN.1 makro OBJECT-TYPE. Definice notifikací (nazývaných také „“) se používají pro popis asynchronních () signálů nesoucích informace o událostech vzniklých ve spravovaných objektech. Pro detailní popis syntaxe a sémantiky notifikací se používá ASN.1 makro NOTIFICATION-TYPE.

Implementace libsmi, knihovna pro jazyk C pro přístup k MIB informacím

Odkazy

Reference

Externí odkazy RFC 2580, standard 58, Conformance Statements for SMIv2 RFC 2579, standard 58, Textual Conventions for SMIv2 RFC 2578, standard 58, Structure of Management Information Version 2 (SMIv2)

Kategorie:ASN.1 Kategorie:Správa sítě Kategorie:Datové modelování