ISO 639-1:2002, Кодови за претставување на имињата на јазиците Дел 1: Алфа-2 код, е првиот дел од серијата на ISO 639 меѓународни (ISO) стандарди за јазични кодови. Дел 1 ја покрива регистрацијата на двобуквени кодови. Има регистрирано 136 вакви кодови. Во регистарот се опфатени позначајните јазици во светот.
Кодовите се корисни кратенки за меѓународно и формално претставување на еден јазик. На пример: Македонскиот е претставен со mk Англискиот е претставен со en Францускиот е претставен со fr Германскиот е претставен со de (од ендонимот Deutsch) Јапонскиот е претставен со ja (иако ендонимот му е Нихонго) Португалскиот е претставен со pt Шпанскиот е претставен со es (од ендонимот Español)
Првичниот стандард за јазични кодови ISO 639 е одобрен во 1967. Бил поделен на два дела, а во 2002 ISO 639-1 станал нова ревизија на тој стандард. Најновиот код е ht додаден на 26 февруари 2003, претставувајќи го хаитскиот креолски јазик. Употребата на овој стандард се препорачува од IETF-јазичните ознаки, воведени со RFC 1766 во март 1995, продолжени во RFC 3066 од јануари 2001 и RFC 4646 од септември 2006. Моменталната верзија е RFC 5646 од септември 2009. ISO 639-1 кодовите се регистрираат во службата Инфотерм (Меѓународен информативен центар за терминологија).
Не се додаваат нови ISO 639-1 кодови ако веќе постои ISO 639-2 код, така што системите кои користат ISO 639-1 и 639-2 кодови, со поретпочитање за 639-1 кодови не би биле приморани да ги менуваат постоечките кодови.ISO 639 Здружен советодавен одбор - Начела на работа при одржувањето на ISO 639
Ако се користи ISO 639-2 код кој покрива група јазици, неговата употреба може да се замени за јазиците кои ќе добијат свој ISO 639-1 код.
+ ISO 639-1 кодови додадени по ревизијата од 2001 г.ISO 639-1ISO 639-2ИмеДодаденПретходно подioidoИдо2002-01-15artwawlnВалонски2002-01-29roalilimЛимбуршки2002-08-02gemiiiiiСичуански Ји2002-10-14sitanargАрагонски2002-12-23roahthatХаитски Креол2003-02-26cpf
Нема наведено посебно правило за постапување со микројазици (видете ISO 639-3).
Поврзано
Наводи
Надворешни врски ISO 639-1/RA ЧПП од Регистарската служба на ISO 639-2
#00639-1 Категорија:ISO 639 стандарди
la:ISO 639#ISO 639-1 nl:ISO 639#ISO 639-1