Simple Mail Transfer Protocol
Simple Mail Transfer Protocol(SMTP) е Internet standard за пренос на електронска пошта (e-mail) низ Internet Protocol (IP) мрежата. SMTP најпрво бил дефиниран од RFC 821 (Семрежен стандард 10) (1982)RFC 821, Simple Mail Transfer Protocol, J.B. Postel, The Internet Society (August 1982), и последен пат ажуриран од RFC 5.321 (2008)a b RFC 5321, Simple Mail Transfer Protocol, J. Klensin, The Internet Society (October 2008) што вклучува еxtended SMTP (ESMTP), тоа е широко распространет протокол денес. SMTP е назначен за транспорт на испрќање е-писма и користи TCP порти 25. Протоколот за нови поднесоци е онолку ефикасен колку и SMTP, но тој користи 587 порти. Додека опслужувачите за електронска пошта и други средства за размена на пошта користат SMTP за испраќање и примање на пораки, апликациите на ниво корисник-клиент единствено користат SMTP само за испраќање пораки на опслужувачи за пренос. За примање порака, корисничките апликации најчесто користат или Post Office Protocol (POP) или Internet Message Access Protocol (MAP), или пак сопствен систем (како Microsoft Exchange или Lotus Notes/Domino) за пристап на поштенските сандачиња на нивните кориснички сметки.
Историјат на SMTP
Различни облици на еден-на-еден електронски пораки се користеа во 60-тите години на минатиот век. Луѓето комуницираа едни со други користејќи системи развиени за специфични mainframe компјутери. Колку повеќе компјутери се меѓусебно поврзани, особено во Владата на САД ARPANET, стандардите се развиваа да им овозможат на корисниците да користат различни средства за да си праќаат e-mail едни на други. SMTP порасна над овие стандарди кои се развиваа во 1970-тите.
SMTP води корени од две имплементации опишани во 1971, Mail Box Protocol, за кој се оспорува дека бил имплементиран,The History of Electronic Mail, Tom Van Vleck: "It is not clear this protocol was ever implemented" но се разговара во RFC 196 и други RFCs, и програмата SNDMSG, која според RFC 2235, Реј Томлинсон од BBN “измислува” испраќање преку ARPANET за TENEX компјутери.The First Network Email , Ray Tomlinson, BBNPicture of "The First Email Computer" by Dan Murphy, a PDP-10 Во ова време, во ARPANET беа поврзани помалку од 50 домаќини.RFC 2235
Дополнителни имплементации вклучуваат FTP Mail и Mail Protocol,RFC 469 - Network Mail Meeting Summary двата од 1973RFC 524 - A Proposed Mail Protocol година. Работењето продолжи да се развива во текот на 1970-тите, сè до 1980 кога ARPANET се претвори во модерениот Internet.RFC 772 - Mail Transfer Protocol Во 1980 година, Џон Поштел го прикажа Mail Transfer Protocol, со што започна да се отстранува од употреба FTP за пошта. SMTP беше објавен како RFC 821, во август 1982 година, исто така, од Поштел.
Стандардот SMTP е развиен во истото време како Usenet, еден-на-многу комуникациска мрежа со некои сличности.
SMTP се распространи широко во употреба во раните 1980-ти. Во тоа време, тоа беше надополнување на Unix to Unix Copy Program (UUCP), кој беше подобро прилагоден за да се справи со размена на е-пошта помеѓу машини кои биле поврзани со прекини. SMTP, од друга страна, работи најдобро кога и двтете машини, онаа која испраќа и онаа која прима, се приклучени на мрежата постојано. И двете користат, store and forward механизам и се примери на push technology. Иако Usenet’s newsgroup сè уште се шири со UUCP меѓу опслужувачи,Tldp.org UUCP поштата практично исчезна,draft-barber-uucp-project-conclusion-05 - The Conclusion of the UUCP Mapping Project заедно со “bang paths” го користат како заглавје со насочувачка порака
Написот за пренапишување на испраќачот содржи технички информации во позадина за историјата на почетниот SMTP и изворното насочување пред RFC 1123.
Наводи:
Натамошно читање: Hughes, L (1998). Internet e-mail Protocols, Standards and Implementation. Artech House Publishers. ISBN 0890069395. Hunt, C (2003). sendmail Cookbook. O'Reilly Media. ISBN 0596004710.
Надворешни врски: Essential Internet Protocols - SMTP SMTP Diagram of e-mail flow (PDF, PNG )
Категорија:Електронска пошта Категорија:Семрежни стандарди