Em segurança da informação, o termo protocolos AAA (Authentication, Authorization and Accounting) é uma referência aos protocolos relacionados com os procedimentos de autenticação, autorização e auditoria. A autenticação verifica a identidade digital do usuário de um sistema, a autorização garante que um usuário autenticado somente tenha acesso aos recursos autorizados e, por fim, a auditoria refere-se a coleta de informações sobre o uso dos recursos de um sistema pelos seus usuários.
Autenticação
A autenticação é uma referência ao procedimento que confirma a validade do usuário que realiza a requisição de um serviço. Este procedimento é baseado na apresentação de uma identidade junto com uma ou mais credenciais. As senhas e os certificados digitais são exemplos de credenciais.
Autorização
A autorização é a concessão de uso para determinados tipos de serviço, dada a um usuário previamente autenticado, com base na sua identidade, nos serviços que requisita e no estado atual do sistema. A autorização pode ser baseada em restrições, que são definidas por um horário de permissão de acesso ou localização física do usuário, por exemplo. A autorização determina a natureza do serviço cujo acesso é permitido a um usuário. Como exemplos de tipos de serviços temos: filtragem de endereço IP, atribuição de endereço, atribuição de rota, serviços diferenciados por QoS, controle de banda/gerenciamento de tráfego, tunelamento compulsório para determinado endpoint e criptografia.
Auditoria O procedimento de auditoria é uma referência à coleta da informação relacionada à utilização de recursos de rede pelos usuários. Esta informação pode ser utilizada para gerenciamento, planejamento, cobrança e etc. A auditoria em tempo real ocorre quando as informações relativas aos usuários são trafegadas no momento do consumo dos recursos. Na auditoria em batch as informações são gravadas e enviadas posteriormente. As informações que são tipicamente relacionadas com este processo são a identidade do usuário, a natureza do serviço entregue, o momento em que o serviço se inicia e o momento do seu término.
Requerimentos RFC 2194 Review of Roaming Implementations RFC 2477 Criteria for Evaluating Roaming Protocols RFC 2881 Network Access Server Requirements Next Generation (NASREQNG) NAS Model RFC 2903 Generic AAA Architecture RFC 2904 AAA Authorization Framework RFC 2905 AAA Authorization Application Examples RFC 2906 AAA Authorization Requirements RFC 3169 Criteria for Evaluating Network Access Server Protocols RFC 3539 AAA Transport Profile RFC 1234 AAA Transport Profile
Lista de Protocolos AAA RADIUS DIAMETER TACACS TACACS+
Alguns protocolos utilizados em combinação com os citados acima : PPP EAP LDAP
Ligações externas Comparação das camadas de enlace e rede com relação à segurança A página da autenticação, autorização e accouting do grupo de trabalho da IETF
Categoria:Segurança da informação