A versão 6 do protocolo de configuração dinâmica de (DHCPv6) é um protocolo de rede usado para configurar s, que utilizam a versão 6 do protocolo de (IPv6), com endereços e prefixos IP e outros dados de configuração necessários para operar em uma rede IPv6. É o equivalente IPv6 do protocolo de configuração dinâmica de para IPv4.

Os s IPv6 podem gerar endereços IP, automaticamente, usando a configuração automática de endereço sem estado (SLAAC) ou podem receber dados de configuração através do DHCPv6.

Os s IPv6 que utilizam configuração automática sem estado podem exigir outras informações além de um endereço IP ou rota. O DHCPv6 pode ser usado para adquirir essas informações, mesmo que não esteja sendo usado para configurar endereços IP. O DHCPv6 não é necessário para configurar s com endereços de servidores do sistema de nome de domínio (DNS) porque eles podem ser configurados usando o protocolo de descoberta de vizinho (NDP), que também é o mecanismo para configuração automática sem estado.

Muitos roteadores IPv6, como roteadores para redes residenciais, devem ser configurados automaticamente (sem intervenção do operador). Esses roteadores exigem não apenas um endereço IPv6 para uso na comunicação com roteadores mas também um prefixo IPv6 para uso na configuração de dispositivos no lado do roteador. A delegação de prefixo DHCPv6 fornece um mecanismo para configurar esses roteadores.

Identificadores

Identificador exclusivo DHCP

O identificador exclusivo DHCP (DUID) é usado pelo cliente para obter um endereço IP do servidor DHCPv6. Possui uma área do tipo DUID de 2 s e uma área identificadora de comprimento variável de até 128 s. Seu comprimento real depende de seu tipo. O servidor compara o DUID com seu banco de dados e entrega os dados de configuração (endereço, tempos de , servidores DNS, etc.) ao cliente. Os primeiros 16 s de um DUID contêm o tipo DUID, do qual existem quatro tipos. O significado do DUID restante depende do tipo.

Quatro tipos são identificados na RFC 8415:

Endereço da camada de enlace mais tempo (DUID-LLT) ID exclusivo atribuído pelo fornecedor com base no número da empresa (DUID-EN) Endereço da camada de (DUID-LL) DUID baseado em UUID (DUID-UUID)

RFC 6939: opção de endereço de camada de do cliente

Devido aos fatos de ser difícil gerenciar vários identificadores em um ambiente de pilha dupla e os DUIDs simplesmente não serem ideais para algumas situações, a RFC 6939 foi lançada oferecendo uma maneira de identificar um com base em seu endereço MAC. Ele define uma maneira de um retransmissor DHCPv6 passar essas informações para um servidor DHCPv6.

Exemplo

Neste exemplo, sem a entrega rápida presente, o endereço de enlace local do servidor é fe80::0011:22ff:fe33:5566 e o endereço de enlace local do cliente é fe80::aabb:ccff:fedd:eeff.

O cliente envia uma solicitação de [fe80::aabb:ccff:fedd:eeff]: 546 para [ff02::1:2]:547. As mensagens do cliente são enviadas para o endereço , de acordo com a seção 14 da RFC 8415. O servidor responde, com um anúncio, do endereço [fe80::0011:22ff:fe33:5566]:547 ao endereço [fe80::aabb:ccff:fedd:eeff]:546. O cliente responde, com um pedido, do endereço [fe80:: aabb:ccff:fedd:eeff]:546 para o endereço [ff02::1:2]:547. O servidor termina com uma resposta do endereço [fe80::0011:22ff:fe33:5566]:547 para o endereço [fe80::aabb:ccff:fedd:eeff]:546.

Padrões IETF

RFC 8415, "Protocolo de configuração dinâmica de para IPv6 (DHCPv6)" - RFCs 3315, 3363, 3736, 4242, 7083, 7283 e 7550 obsoletas. RFC 3319, "opções do protocolo de configuração dinâmica de (DHCPv6) para servidores de protocolo de inicialização de sessão (SIP)". RFC 3646, "Opções de configuração de DNS para protocolo de configuração dinâmica de para IPv6 (DHCPv6)". RFC 4704, "a opção de cliente de nome de domínio totalmente qualificado (FQDN) do protocolo de configuração dinâmica de para IPv6 (DHCPv6)". RFC 5007, "consulta de concessão DHCPv6". RFC 6221, "agente leve de retransmissão DHCPv6 (LDRA)" - atualiza a RFC 3315, errata. RFC 6355, "definição do identificador DHCPv6 exclusivo baseado em UUID (DUID-UUID)". RFC 6939, "opção de endereço de camada de enlace do cliente no DHCPv6".

Ver também

Protocolo de descoberta de vizinho, que também suporta configuração de DNS

Ligações externas

Parâmetros DHCPv6 IANA (em inglês). Inteligência IPv6: DHCPv6, comparação de pacotes e implementações DHCPv6 (última atualização: abril de 2009) (em inglês). Pronto para IPv6: DHCPv6, lista de implementações de DHCPv6 certificadas IPv6 Fase 2 (última atualização: dezembro de 2012) (em inglês).

Categoria:IPv6 Categoria:Protocolos de camada de aplicação Categoria:Protocolos da Internet