Uniform Resource Name (URN)Uniform Resource Name (URN) Namespace Registration Transition - Internet Engineering Task Force (IETF)Uniform Resource Names (URN) Namespaces (IANA), é um termo técnico (e anglicismo de tecnologia da informação) que foi traduzido para a língua portuguesa como "nome uniforme de recurso", é um tipo de URI que usa o URN Scheme e que tem por objetivo a identificação única do recurso, de forma persistente e independente da sua localização.

A ideia básica dos URNs como identificadores persistentes é permitir a separação estrita entre identificação (nome único) e localização (endereços URL que podem oferecer o recurso identificado).

Os requisitos funcionais do padrão URN encontra-se fixados na norma RFC 1737, a sua sintaxe na RFC 2141.

Sintaxe de um URN

A norma RFC 2141 (de 1997 mas ainda não-homologada) descreve em BNF:

<URN> ::= "urn:" <NID> ":" <NSS>

onde <NID> é o Namespace Identifier, e <NSS> é o Namespace Specific String. As palavras e pontuações entre aspas são obrigatórias. O primeiro elemento da sequência, "urn:", é case-insensitive. O NID determina a interpretação sintática da string NSS.

Exemplos urn:isbn:0451450523 O URN para "The Last Unicorn", identificado por seu número ISBN. urn:lex:br:federal:lei:2008-06-19;11705 O URN para a "Lei Seca" do Brasil, ou "Lei Federal 11.705 de 2008", identificado por seu nome Lex. urn:isan:0000-0000-9E59-0000-O-0000-0000-2 O URN para "Homem-aranha (filme)", identificado por seu audiovisual number. urn:issn:0167-6423 O URN para o periódico científico "Science of Computer Programming", identificado pelo seu número serial. urn:ietf:rfc:2648 O URN para a RFC 2648 do IETF.

urn:mpeg:mpeg7:schema:2001Default Namespace Rules for MPEG-7 video metadata. urn:oid:2.16.840The URN corresponding to the OID for the United States. urn:uuid:6e8bc430-9c3a-11d9-9669-0800200c9a66A URN using a version 1 - Universally Unique Identifier (UUID). urn:uci:I001+SBSi-B10000083052The Universal Content Identifier ID issued to a drama Snow Flower supplied by SBS broadcasting company (RFC 4179)

Resolvedores O "Resolvedor de URN" (URN resolver) é responsável por interpretar uma URN dada ou consultas sobre URNs, usualmente traduzindo o nome URN em um ou mais URLs. Softwares do tipo server-side URN resolver são definidos na RFC 2169.

Exemplo de Resolvedor URN persistente em funcionamento (ver também urn:lex): http://www.lexml.gov.br/urn .

Resolvedores locais, centrais e federados: a resolução de URNs é idealmente realizada por um PURLs (Persistent Uniform Resource Locators)PURLs (Persistent Uniform Resource Locators), mas pode ser também uma ferramenta para portais locais. Uma forma de garantir a consistência e operacionalidade entre resolvedors locais e centrais é a federação: o URN resolver local quando não sabe resolver, repassa o pedido para o central.

Ver também URL (Uniform Resource Locator) URI (Uniform Resource Identifier) IRI (Internationalized Resource Identifier) XRI (eXtensible Resource Identifier) IANA (Internet Assigned Numbers Authority) ICANN (Internet Corporation for Assigned Names and Numbers) W3C (World Wide Web Consortium)

Categoria:Tecnologia da informação