H.248 (ранее также MEGACO) — протокол используемый между элементами телекоммуникационных сетей: медиашлюзом () и контроллером шлюзов (). Поддерживает различные системы сигнализации сетей с коммутацией каналов, включая тоновую сигнализацию, ISDN, ISUP, QSIG и GSM. Закреплен как стандартный протокол IMS, наряду с SIP и Diameter.

История Протокол разрабатывался 16-й группой ITU-T с 1997 года по 2000 год и был утверждён 15 июня 2000 года. Стандартизован рекомендациями ITU-T с H.248.1 (основное описание протокола) по H.248.88 (наборы пакетов).

Аналогичный протокол, разработанный IETF в 2000 году и дополненный в 2003 имел название MEGACO (RFC 3015 и RFC 3525). Многие черты MEGACO получил от протокола управления шлюзами MGCP. В 2008 году специалисты IETF в RFC 5125 перевели MEGACO (и соответствующий RFC 3525) в статус исторического наследия, оставив приоритет за стандартом H.248.

Принципы работы Архитектура Стандарт H.248.1 международного совета электросвязи (ITU) даёт следующие определения типов устройств, которые используются в протоколе: Шлюз доступа (Access Gateway) - шлюз, который предоставляет интерфейс типа пользователь-сеть (User-Network Interface), например такой как ISDN. Медиашлюз (Media Gateway, MG) - устройство которое преобразует медиаданные, предоставленные в сети одного типа, в формат, необходимый для сети другого типа. Например, MG может завершать однонаправленные каналы из сети с коммутацией каналов (такие как DS0) и медиапотоки из сети с коммутацией пакетов (потоки RTP в IP-сети). Этот шлюз может обрабатывать аудио, видео и ITU-T T.120 по отдельности или в любой комбинации, а также может выполнять полнодуплексную, т.е. двустороннюю передачу медиаданных. Медиашлюза также может воспроизводить аудио / видео сообщения и выполнять другие функции IVR или может поддерживать мультимедийные конференции. Контроллер медиашлюзов (Media Gateway Controller, MGC) - устройство или приложение, управляющее соединением и состоянием вызова посредством управления медиа-каналами в медиашлюзе. Шлюз сигнализации SCN FAS (SCN FAS Signalling Gateway, SG) - эта функция содержит интерфейс сигнализации SCN, который завершает ОКС-7, ISDN или другие каналы сигнализации, где канал управления вызовом и каналы передачи данных расположены в одном и том же физическом диапазоне. Домашний шлюз (Residential Gateway) - аппаратный шлюз, который соединяет аналоговую линию с пакетной сетью. Residential Gateway обычно содержит одну или две аналоговые линии для подключения телефонных аппаратов и расположен в помещении клиента. Многоточечный блок управления (Multipoint Control Unit, MCU) - сущность или объект, управляющий настройкой и координацией многопользовательской конференции, которая обычно включает в себя обработку аудио, видео и данных. Дескриптор (descriptor) - синтаксический элемент протокола, который группирует связанные свойства. Например, свойства медиапотока в медиа-шлюзе могут быть установлены MGC путем включения соответствующего дескриптора в команду.

Фактически, ключевыми устройствами в H.248 являются контроллер (MGC) и медиашлюз (MG). Основные сущности, которыми они оперируют в рамках взаимодействия - это контексты (context) и окончания (termination).

Окончания (termination) Эти источники или приемники одного или нескольких медиапотоков или управляющих потоков. Окончание может быть физическим или эфемерным (временным / виртуальным). Контексты Это звездообразные соединения, созданные путем объединения нескольких окончаний. Контекст - логический объект в медиашлюзе, который является ассоциацией между набором окончаний. НУЛЕВОЙ контекст содержит все несвязанные окончания. ContextID идентифицирует контекст. Нормальный, «активный» контекст может иметь физическое оконечный (скажем, один DS0 в DS3) и одно временное (RTP-поток, соединяющий шлюз с сетью). Контексты создаются и освобождаются MG под управлением контроллером медиашлюзов (MGC). Контекст создается путем добавления первого завершения и освобождается путем удаления (вычитания) последнего завершения. Окончание может иметь более одного потока, и поэтому контекст может быть многопоточным. Потоки аудио, видео и данных могут разделяться в контексте между несколькими окончаниями.

Сообщения и команды H.248 Контроллер медиашлюзов всегда сам управляет медиа-каналами, доступными на медиашлюзе посредством управления конкретными контекстами и окончаниями. При изменении состояния вызова, MGC отправляет соответствующее сообщение на шлюз и ожидает подтверждения.

Каждое сообщение является транспортным механизмом передачи команд, а не самой командой, в отличие от большинства прочих телекоммуникационных протоколов.

Команды протокола: Add Move Subtract Notify Modify AuditValue AuditCapabilites ServiceChange

Типовой сценарий обмена сообщениями в рамках вызова

Контроллер Медиашлюз медиашлюзов (MGC)

[ ISUP IAM (Начало вызова) ]

| ------ ADD REQUEST ------> | | <------- ADD REPLY ------- | | ------ RESPONSE ---------> | | ----- MODIFY REQUEST ----> | | <------ MODIFY REPLY ----- | | ------ RESPONSE ---------> |

[ ISUP ACM (Набранный номер получен) ]

| ----- MODIFY REQUEST ----> | | <------ MODIFY REPLY ----- | | ------ RESPONSE ---------> | | ---- MODIFY REQUEST -----> | | <------ MODIFY REPLY ----- | | ------- RESPONSE --------> |

[ ISUP ANM (Контроль Посылки Вызов, гудок) ]

| ----- MODIFY REQUEST ----> | | <------ MODIFY REPLY ----- | | ------- RESPONSE --------> |

Соединение установлено. Разговор.

[ ISUP REL (Завершение вызова) ]

| --- SUBSTRACT REQUEST ---> | | <---- SUBSTRACT REPLY ---- | | ------- RESPONSE --------> |

Структура сообщений

С точки зрения сообщения:

Сообщение { Транзакция{ Действие{ Контекст{ Команда{ Окончание{ Дескриптор{ Пакет }}}}}}}

По аналогии с моделью OSI иерархия уровней взаимодействия с точки зрения передачи по сети (пакетной или ATM) выглядит следующим образом.

H.248 TCP UDP SCTP IPEthernetATM

Сравнение с MGCP

Ниже представлены общие аспекты и различия между Megaco/H.248 и MGCP:

H.248/Megaco MGCPВызов представляется как терминация (завершение) контекста Вызов представляется конечным устройством с соединениемВозможные типы вызовов включают в себя любую комбинацию мультимедиа и конференц-связи Возможные типы вызовов это только точка-точка или многоточкаСинтаксис текстовый или бинарный Синтаксис текстовыйТранспортный уровень TCP, UDP или SCTP Транспортный уровень - UDPСтандартный протокол управления медиа-шлюзом (Media Gateway Control) IETF статус - Информационный. MGCP не определяет какого-либо Интернет-стандарта Определён ITU (в прошлом разрабатывался совместно IETF и ITU) Управляется индустрией. Множество компаний имеют собственную реализацию MGCP

Ссылки «Packetizer», информация по протоколу Протокол Megaco/H.248. Справочник по телекоммуникационным протоколам Протокол H.248. Учебное пособие ITU-T Recommendation H.248.1 (03/13) Версия 3 ITU-T Recommendation H.248.2 (03/13) Передача факса и текста, пакеты обслуживающие вызов ITU-T Recommendation H.248.3 (03/13) Элементы пользовательского интерфейса и пакеты с параметрами действий ITU-T Recommendation H.248.8 (03/13) Коды ошибок и причины изменения обслуживания в сообщении service change ITU-T Recommendation H.248.39 (05/06) SDP идентификаторы и регулярные выражения (wildcard) для H.248 ITU-T Recommendation H.248.47 (07/08) Пакет статистики (Statistic conditional reporting package)

Категория:Рекомендации ITU-T Категория:IP-телефония