IPv4 () — четверта версія мережевого протоколу IP. Перша версія протоколу, яка набула широко розповсюдження. Протокол IPv4, описаний у RFC 791 (вересень 1981 року), прийшов на заміну описаному у RFC 760 (січень 1980 року). Використовує 4 байтну форму запису адрес пристроїв в комп'ютерній мережі.
Адресація
IPv4 використовує 32-бітні (4 байтні) адреси, які обмежують адресний простір (себто 28×4) можливими унікальними адресами.
Формою запису IP-адреси (IPv4) зазвичай є запис у вигляді 4 десяткових чисел від 0 до 255 (28), розділених крапками, наприклад: 127.0.0.1 (посилання пристрою на самого себе), або 91.198.174.225 (адреса ресурсу http://uk.wikipedia.org)
Деякі адреси IPv4 зарезервовані для спеціальних цілей та не можуть бути глобально маршрутизованими (доступними з будь-якого пристрою, що підключений до мережі інтернет). Так для приватних IP-адрес («сірих IP») в локальних мережах зарезервовано близько 18 млн адрес. Ще близько 270 млн адрес зарезервовано для групових передач ().
Обмежене число унікальних адрес у ~4.3 млрд у зв'язку з бурхливим розвитком Інтернету та резервуванням діапазону ~290 млн було вичерпане. року організація IANA видала останні 5 блоків IP-адрес організації Регіональних Інтернет Регістрів (RIR).
Задля вирішення цієї проблеми ще з 1990-их розвивався протокол IPv6, запущений з 2006 року.
Зарезервовані адреси
+ Підмережа Призначення 0.0.0.0/8RFC1700: Assigned Numbers Адреса джерела пакету 127.0.0.0/8 Підмережа для комунікацій всередині хосту (див. localhost) 100.64.0.0/10Shared Address Space. RFC6598: Використовується в мережах інтернет та сервіс провайдерів, для запобігання перетину адресного простору мережі провайдера та клієнтів. Shared Address Space 169.254.0.0/16RFC3927: Dynamic Configuration of IPv4 Link-Local Addresses Канальні (link-local) адреси 192.0.2.0/24RFC5737: IPv4 Address Blocks Reserved for Documentation Приклади та документація 198.51.100.0/24 Приклади та документація 203.0.113.0/24 Приклади та документація 198.18.0.0/15RFC2544: Benchmarking Methodology for Network Interconnect Devices Для стендів тестування потужності 10.0.0.0/8RFC1918: Address Allocation for Private Internets Для використання у приватних мережах 172.16.0.0/12 Для використання у приватних мережах 192.168.0.0/16 Для використання у приватних мережах 240.0.0.0/4RFC3330: Special-Use IPv4 Addresses Зарезервовано для використання у майбутньому 255.255.255.255BROADCASTING INTERNET DATAGRAMS Широкомовна адреса+
Підмережа 224.0.0.0/4 Зарезервована для багатоадресної.
Вичерпання IPv4 адрес
Оцінки повного вичерпання IPv4 адрес різнились у 2000-их, були різні прогнози. Так у 2003 році директор APNIC Пол Вілсон () заявляв, що, зважаючи на темпи розростання мережі Інтернет, вільного адресного простору вистачить на одне—два десятиліття. У вересні 2005 року компанія Cisco Systems зазначила, що пулу доступних адрес вистачить на 4—5 років. У вересні 2010, виходячи з даних IANA, весь пул адрес IPv4 буде виділений реєстратурам (RIR) до середини 2011 року (), в листопаді ця дата була перенесена на березень 2011. 3 лютого 2011 року IANA виділила останні п'ять блоків IP-адрес /8 (IPv4).
Див. також
Internet Protocol IPv5 — експериментальний протокол; IPv6 — шоста версія протоколу IP;
Примітки