MIME тип — код, який визначає формат файлу або тип контенту, що передається мережею Інтернет. Складається з двох частин. Коди визначає та офіційно оприлюднює тільки IANA. MIME типи спочатку були визначені в RFC 2045 у листопаді 1996 року, як частина МІМЕ специфікації, для визначення типу вмісту повідомлень електронної пошти та вкладень. З часом, MIME типи почали використовувати в інших протоколах, таких як HTTP, та в форматах документів, таких як HTML, XML тощо.

Конструкція коду Код МІМЕ складається з типу та підтипу, які можуть організовувати дерево. Також додатково код мож мати суфікс та параметри: тип "/" [дерево "."] підтип ["+" суфікс] *[";" параметр]

На поточний час, зареєстрованими типами є: application, audio, example, font, image, message, model, multipart, text та video.

Наприклад, HTML файл може мати наступний MIME тип text/html; charset=UTF-8. В цьому прикладі: text — тип; html — підтип; charset=UTF-8 — додатковий параметр, що вказує на кодування символів, яке застосовано в цьому документі.

Перелік МІМЕ-типів Нижче наведено найбільш поширені МІМЕ-типи з підтипами та посилання на відповідний формат.

Дані в нестандартизованих форматах Використовуються для позначення форматів, що обробляються стороніми додатками. application/atom+xml — Atom application/EDI-X12 — EDI X12 (RFC 1767) application/EDIFACT — EDI EDIFACT (RFC 1767) application/json — структуровані дані в форматі JSON application/javascript — JavaScript (RFC 4329) application/octet-stream — бінарні дані невизначеного формату (RFC 2046)HTTP/1.1: Entity . W3.org. Retrieved on 2010-09-29. application/ogg — Ogg (RFC 5334) application/pdf — PDF (RFC 3778) application/postscript — PostScript (RFC 2046) application/soap+xml — SOAP (RFC 3902) application/font-woff — шрифт в форматі Web Open Font Format application/xhtml+xml — XHTML (RFC 3236) application/xml-dtd — DTD (RFC 3023) application/xop+xml — XOP application/zip — стиснуті дані в форматі ZIP application/gzip — стсинуті дані в форматі Gzip application/x-bittorrent — BitTorrent application/x-tex — TeX application/xml — XML

Звукові дані audio/basic — mulaw аудіо, 8 кГц, 1 канал (RFC 2046) audio/L24 — 24bit Linear PCM аудіо, 8–48 кГц, 1-N каналів (RFC 3190) audio/mp4 — MP4 audio/aac — AAC audio/mpeg — MP3 или др. MPEG (RFC 3003) audio/ogg — Ogg Vorbis, Speex, Flac (RFC 5334) audio/vorbis — Vorbis (RFC 5215) audio/x-ms-wma — Windows Media Audio audio/x-ms-wax — Windows Media Audio audio/vnd.rn-realaudio — RealAudioRealPlayer Customer Support Answer 2559 audio/vnd.wave — WAV (RFC 2361) audio/webm — WebM

Зображення image/gif — GIF (RFC 2045 та RFC 2046) image/jpeg — JPEG (RFC 2045 та RFC 2046) image/pjpeg — JPEG image/png — Portable Network Graphics (RFC 2083) image/svg+xml — SVG image/tiff — TIFF (RFC 3302) image/vnd.microsoft.icon — ICO image/vnd.wap.wbmp — WBMP image/webp — WebP

Повідомлення message/http — (RFC 2616) message/imdn+xml — IMDN (RFC 5438) message/partial — E-mail (RFC 2045 та RFC 2046) message/rfc822 — E-mail; EML-файли, MIME-файли, MHT-файли, MHTML-файли (RFC 2045 та RFC 2046)

Дані з моделями model/example — (RFC 4735) model/iges — IGS файли, IGES файли (RFC 2077) model/mesh — MSH файли, MESH файли (RFC 2077), SILO файли model/vrml — WRL файли, VRML файли (RFC 2077) model/x3d+binary — X3D дані в двійковому форматі model/x3d+vrml — X3D дані в форматі VRML model/x3d+xml — X3D дані в форматі XML

Частина даних multipart/mixed — E-mail (RFC 2045 и RFC 2046) multipart/alternative — E-mail (RFC 2045 та RFC 2046) multipart/related — E-mail (RFC 2387 та MHTML (HTML mail)) multipart/form-data — дані з Вебформа (RFC 2388) multipart/signed — підписана частина даних (RFC 1847) multipart/encrypted — зашифрована частина даних (RFC 1847)

Текстові дані text/cmd — пакетний файл text/css — Cascading Style Sheets (RFC 2318) text/csv — CSV (RFC 4180) text/html — HTML (RFC 2854) text/javascript — JavaScript-скрипти (RFC 4329) text/plain — простий текст (RFC 2046 та RFC 3676) text/php — PHP-скрипт text/xml — дані в форматі XML (RFC 3023) text/markdown — дані в форматі Markdown (RFC 7763) text/cache-manifest — маніфест кешу браузера (RFC 2046)

Відео video/mpeg — MPEG-1 (RFC 2045 та RFC 2046) video/mp4 — MP4 (RFC 4337) video/ogg — Ogg Theora або в іншому форматі (RFC 5334) video/quicktime — QuickTime video/webm — WebM video/x-ms-wmv — відео в форматі Windows Media Video video/x-flv — відео в форматі FLV video/3gpp — відео в форматі .3gpp або .3gp video/3gpp2 — відео в форматі .3gpp2 або .3g2

Див. також Узагальнений ідентифікатор типу Сигнатура файлу (перелік) Магічне число (програмування)

Примітки