Internet Printing Protocol (IPP) je specializovaný komunikační protokol používaný mezi klientskými zařízeními (počítači, mobilními telefony, tablety atd.) a tiskárnami (nebo tiskovými servery), který používá TCP port 631. Protokol umožňuje klientům odeslat jednu nebo více tiskových úloh na síťově připojenou tiskárnu nebo tiskový server a provádět úkoly, jako je dotazování na stav tiskárny, získávání stavu tiskových úloh nebo rušení jednotlivých tiskových úloh.
IPP je základem několika certifikačních standardů pro tiskárny včetně AirPrint, IPP Everywhere, Mopria Alliance a je podporován více než 98 % dnes prodávaných tiskáren. Firma Microsoft preferuje od roku 2026 tisk z Microsoft Windows pomocí protokolu IPP.
Charakteristika Stejně jako všechny protokoly založené na IP protokolu může i IPP komunikovat lokálně nebo přes internet. Na rozdíl od jiných tiskových protokolů IPP podporuje řízení přístupu, ověřování a šifrování, což z něj činí mnohem výkonnější a bezpečnější tiskový mechanismus než starší protokoly.
IPP je implementován pomocí HTTP protokolu (Hypertext Transfer Protocol) a dědí všechny funkce streamování a zabezpečení HTTP. Autorizace může probíhat prostřednictvím mechanismu ověřování přístupu Digest protokolu HTTP, GSSAPI nebo jiných metod ověřování HTTP. Šifrování je zajištěno pomocí vrstvy TLS, a to buď v tradičním režimu always-on používaném protokolem HTTPS, nebo pomocí rozšíření HTTP Upgrade na HTTPS (RFC 2817). Pro ověřování pomocí TLS lze použít certifikáty s veřejným klíčem. Streamování je podporováno pomocí HTTP chunking. Dokument určený k tisku se obvykle odesílá jako datový stream.
IPP umožňuje tisk dokumentů v různých formátech. PWG definovala pro tento účel obrazový formát s názvem PWG Raster. Mezi další formáty patří PDF nebo JPEG, v závislosti na možnostech cílové tiskárny.
IPP používá tradiční model klient-server, kdy klienti odesílají na tiskárnu IPP zprávy pomocí HTTP POST požadavků s MIME typem „application/ipp“. Zprávy s IPP požadavky se skládají z párů klíč–hodnota používající vlastní binární kódování, po nichž následuje tag „konec atributů“ a veškerá data dokumentu potřebná pro požadavek (například dokument, který má být vytištěn). Odpověď IPP je odeslána zpět klientovi v odpovědi na HTTP POST požadavek, opět s použitím typu média MIME „application/ipp“.
IPP mimo jiné umožňuje klientovi:
dotazovat se na možnosti tiskárny (například podporované znakové sady, typy médií a formáty dokumentů) odeslat tiskové úlohy do tiskárny dotaz na stav tiskárny dotaz na stav jedné nebo více tiskových úloh zrušit dříve odeslané úlohy
IPP používá TCP s portem 631 jako svým dobře známým portem.
Mezi produkty používající protokol IPP patří Universal Print od společnosti Microsoft, CUPS (který je součástí systému Apple macOS a mnoha distribucí BSD a Linuxu a je referenční implementací pro většinu verzí protokolu IPP), The language "CUPS Software (IPP Reference Implementation)" appeared on this page since a point between 1 September 2009 and 12 January 2010, though no mention of a reference implementation is found in the published standard. Novell iPrint a verze pro Microsoft Windows počínaje systémem MS Windows 2000. Systémy Windows XP a Windows Server 2003 nabízely IPP tisk přes HTTPS. Systémy Windows Vista, Windows 7, Windows Server 2008 a 2008 R2 též podporovaly IPP tisk přes RPC v zóně zabezpečení „Střední-Nízká“.
Historie IPP vznikl jako návrh společnosti Novell na vytvoření projektu internetového tiskového protokolu v roce 1996. Výsledkem byl návrh sepsaný společnostmi Novell a Xerox s názvem Lightweight Document Printing Application (LDPA), odvozený z ECMA-140: Document Printing Application (DPA). Přibližně ve stejnou dobu společnost IBM veřejně navrhla protokol zvaný HyperText Printing Protocol (HTPP) a společnosti HP i Microsoft zahájily práce na nových tiskových službách pro tehdy připravovaný operační systém Windows 2000. Každá ze společností se rozhodla zahájit společný projekt internetového tiskového protokolu v rámci Printer Working Group (PWG) a vyjednala s řediteli aplikačních oblastí v rámci Internet Engineering Task Force (IETF) schůzku typu „birds-of-a-feather“ (BOF). Schůze BOF v prosinci 1996 ukázala dostatečný zájem o vývoj tiskového protokolu, což vedlo k vytvoření pracovní skupiny IETF Internet Printing Protocol (ipp),. která skončila v roce 2005.
Práce na IPP pokračuje v pracovní skupině PWG Internet Printing Protocol, kde bylo publikováno 23 kandidátských standardů, 1 nový a 3 aktualizované dokumenty IETF RFC a několik registračních dokumentů a dokumentů o osvědčených postupech, které poskytují rozšíření IPP a podporu pro různé služby, včetně 3D tisku, skenování, faxování, cloudových služeb a celkové správy systémů a zdrojů.
IPP/1.0 byl publikován jako série experimentálních dokumentů (RFC 2565, RFC 2566, RFC 2567, RFC 2568, RFC 2569 a RFC 2639) v roce 1999.
Standard IPP/1.1 následoval jako návrh standardu v roce 2000 s podpůrnými dokumenty v letech 2001, 2003 a 2015 (RFC 2910, RFC 2911, RFC 3196, RFC 3510 a RFC 7472). Standard IPP/1.1 byl navržen v lednu 2017 (RFC 8010, RFC 8011) a poté byl v červnu 2018 přijat jako internetový standard 92 (STD 92).
Standard IPP 2.0 byl publikován jako kandidátská verze PWG v roce 2009 (PWG 5100.10-2009). a definoval dvě nové verze IPP (2.0 pro tiskárny a 2.1 pro tiskové servery) s dalšími požadavky na shodu nad rámec IPP 1.1. Následná kandidátská verze jej v roce 2011 nahradila definováním další verze 2.2 pro produkční tiskárny (PWG 5100.12-2011).. Tato specifikace byla aktualizována a schválena jako plnohodnotný standard PWG (PWG 5100.12-2015). v roce 2015.
Standard IPP Everywhere byl publikován v roce 2013 a poskytuje společný základní standard pro tiskárny, které podporují tzv. „bezovladačový“ tisk z klientských zařízení. Staví na standardu IPP a specifikuje další pravidla pro interoperabilitu, například seznam formátů dokumentů, které musí tiskárny podporovat. V roce 2016 byla publikována odpovídající příručka pro autocertifikaci a sada nástrojů, které umožňují výrobcům tiskáren a implementátorům tiskových serverů certifikovat svá řešení podle publikované specifikace a být uvedeni na stránce tiskáren IPP Everywhere, kterou spravuje PWG.
Odkazy
Reference
Související články CUPS LPP
Kategorie:Aplikační protokoly IP Kategorie:Tiskové techniky